Erro ‘PHP Extensions “0″ must be loaded.’ no Magento

Olá Galera,

Estes dias passei por um probleminha ao tentar instalar o Magento no Ubuntu que me deixou um pouco intrigado: PHP Extensions “0″ must be loaded. O que seria isso?

Bem, aparentemente é um probleminha de compatibilidade entre o Magento e o PHP 5.4 que, para mim, apenas acontece no Ubuntu 12.10.

Não se preocupem, pois isso é muito simples de se resolver, mas é preciso que tomem o cuidado de voltar á configuração original após ter terminado a instalação do Magento.

Abra o arquivo [Path para o Magento]/app/code/core/Mage/Install/etc/config.xml e procure pelo seguinte bloco:

<extensions>
<pdo_mysql/>
</extensions>

Agora que encontramos podemos alterá-lo para:

<extensions>
<pdo_mysql>1</pdo_mysql>
</extensions>

Com isso você conseguirá prosseguir com sua instalação do Magento e finalizá-la.

Lembre-se: como regra, nunca altere nenhum arquivo do Core do Magento, portanto, após concluir a instalação, volte a configuração ao seu estado original.

Um abraço e até a próxima!

2014-09-02T19:30:49+00:00

RECEBA DICAS VALIOSAS NO SEU EMAIL

x